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CFD and Software 

Design and grid generation with Gambit 2.4.6: 

”Project Steps”  

 

Important! this document was inspired by the Gambit 2.4.6 and Fluent 6.3.26 User 

Guide and presented here to students after being well reorganized and structured from 

a pedagogical point of view. 

 

Step 1: Create Geometry in GAMBIT 

If you would prefer to skip the mesh generation steps, you can create a working 

directory (see below), download the mesh from my URL (right click and save as 

pipe.msh) into the working directory and go straight to step 4. 

Strategy for Creating Geometry 

In order to create the rectangle, we will first create the vertices at the four corners. 

We'll then join adjacent vertices by straight lines to form the "edges" of the rectangle. 

Lastly, we will create a "face" corresponding to the area enclosed by the edges. In Step 

2, we'll mesh the face i.e. the rectangle. Note that in 3D problems, you'll have to form a 

"volume" from faces. So the hierarchy of geometric objects in GAMBIT is vertices --> 

edges --> faces --> volumes. 

Create a Working Directory 

Create a folder called pipe in a convenient location. We will use this as the working 

folder in which files created during the session will be stored. 

Start GAMBIT 

Start your command prompt. 

Start > Programs > Lab Apps > Fluent Inc Products > Gambit 2.4. > Gambit 2.4. 

This brings up the GAMBIT startup window. Click Browse and select the folder that 

you just created. Enter –id pipe in the options box to tell GAMBIT to use pipe as the 

default file prefix, then click Run. (Figure 1) 
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Figure 1. Gambit startup 

 Note! In Windows, the Exceed X-server starts up before the GAMBIT interface 

comes up. Exceed is a third-party application needed to render the interface in 

Windows ( GAMBIT was originally developed under Unix). To make best use of 

screen real estate, move the windows and resize them so that you approximate 

this screen arrangement. This way you can read instructions in the browser 

window and implement them in GAMBIT. 

 You can resize the text in the browser window to your taste and comfort: 

In Internet Explorer: Menubar > View > Text Size, then choose the appropriate font 

size.  

In Netscape: Menubar > View > Increase Font or Menubar > View > Decrease Font. 

The GAMBIT Interface consists of the following: 

 Main Menu Bar : 

 
Figure 2.  Main Menu bar 

Note that the job name pipe appears after ID: in the title bar of the Utility Menu.  

 Operation Toolpad: 
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Figure 3. Operation Toolpad 

We will more or less work our way across the Operation Toolpad as we go through 

the solution steps. Notice that as each of the top buttons is selected, a different "sub-

pad" appears. The Geometry sub-pad is shown in the above snaphot. 

 Global Control Toolpad: 

 
Figure 4. Global Control Toolpad 

The Global Control Toolpad has options such as Fit to Screen  and Undo  

that are very handy during the course of geometry and mesh creation. 

 GAMBIT Graphics: 

 

Figure 5. GAMBIT Graphics 

This is the window where the graphical results of operations are displayed. 
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 GAMBIT Description Panel: 

 
Figure 6. Panel Description  

The Description Panel contains descriptions of buttons or objects that the mouse is 

pointing to. Move your mouse over some buttons and notice the corresponding text in 

the Description Panel. 

 GAMBIT Transcript Window: 

 
Figure 7. Transcript Window "Journal" 

 

This is the window to which output from GAMBIT commands is written and which 

provides feedback on the actions taken by GAMBIT as you perform operations. If, at 

some point, you are not sure you clicked the right button or entered a value correctly, 

this is where to look to figure out what you just did. You can click on the arrow button 

in the upper right hand corner to make the Transcript window full-sized. You can click 

on the arrow again to return the window to its original size. Go ahead, give this a try. 

Select Solver 

If the window titlebar does not say the solver is FLUENT 5/6, then you need to specify: 

Main Menu > Solver > FLUENT 5/6 

Verify this has been done by looking in the Transcript Window where you should see: 

 

The boundary types that you will be able to select in step 3 depends on the solver 

selected. 

We can assume that the flow is axisymmetric. The problem domain is: 

 
where r and x are the radial and axial coordinates, respectively. 

Strategy for creating geometry 
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We will put the origin of the coordinate system at the lower left corner of the 

rectangle. The coordinates of the corners are shown in the figure 8 below: 

 
Figure 8. Schematic of damain problem 

We will first create four vertices at the four corners and join adjacent vertices to get the 

edges of the rectangle. We will then form a face that covers the area of the rectangle. 

 

 Create Vertices : 

Find the buttons described below by pointing the mouse at each of the buttons and 

reading the Description Window. Operation Toolpad > Geometry Command Button 

> Vertex Command Button > Create Vertex  . 

Notice that the Create Vertex button has already been selected by default. After you 

select a button under a sub-pad, it becomes the default when you go to a different subpad 

and then come back to the sub-pad. 

Create the vertex at the lower-left corner of the rectangle: 

Next to x: enter value 0.  

Next to y: enter value 0.  

Next to z: enter value 0 (these values should be defaults).  

Click Apply.  

This creates the vertex (0,0,0) which is displayed in the graphics window (figure 9). 

 
Figure 9. Vertex dialogue Box 

In the Transcript window, GAMBIT reports that it "Created vertex: vertex.1". The 

vertices are numbered vertex.1, vertex.2 etc. in the order in which they are created. 

Repeat this process to create three more vertices: 

Vertex 2: (0,0.1,0) 
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Vertex 3: (8,0.1,0)  

Vertex 4: (8,0,0) 

 Note that for 2D problem, the z-coordinate can always be left to the default value of 0. 

Operation Toolpad > Global Control > Fit to Window Button   (figure 4). 

This fits the four vertices of the rectangle we have created to the size of the Graphics 

Window.  

 

Figure 10. View of the four vertices on graphics window 

 

 Create Edges : 

We will now connect appropriate pairs of vertices to form edges. To select any entity in 

GAMBIT, hold down the Shift key and click on the entity. 

Operation Toolpad > Geometry Command Button > Edge Command Button > 

Create Edge   

Select two vertices that make up an edge of this rectangle by holding down the Shift 

button and clicking on the corresponding vertices (figure 11). As each vertex is picked, 

it will appear red in the Graphics Window. Then let go of the Shift button. We can check 

the selected vertices by clicking on the up-arrow next to Vertices:. 

 
Figure 11. Selection box of vertices 

This will bring up a window containing the vertices that have been selected. Vertices 

can be moved from the Available and Picked lists (figure 12) by selecting them and then 

pressing the left or right arrow buttons. 
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Figure 12. Picked list of sellected objects 

After the correct vertices have been selected, click Close, then click Apply in the Create 

Straight Edge window. 

Repeat this process to create a rectangle (figure 13). 

 

Figure 13. Rectangle of the problem domain 

 Create Face : 

Operation Toolpad > Geometry Command Button > Face Command Button > 

Form Face   

To form a face out of the area enclosed by the four lines, we need to select the four ledges 

that enclose this area (figure 14). This can be done by holding down the Shift key, 

clicking on each line (notice that the currently selected line appears red), and then 

releasing the Shift key after all four lines have been selected. 

Alternatively, an easier way to do this would be to click on the up arrow next to edges: 

 
Figure 14. Selection box of edges 

This will bring up the Edge List window. Click on All-> to select all of the edges at once. 

Click Close. 
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Figure 15. Picked list of sellected objects 

Step 2: Mesh Geometry in GAMBIT 

We will now create a mesh on the rectangular face with 100 divisions in the axial 

direction and 5 divisions in the radial direction. We will first mesh the four edges and 

then the face. The desired grid spacing is specified through the edge mesh. 

Mesh Edges 

Operation Toolpad > Mesh Command Button > Edge Command Button >  Mesh 

Edges   

Shift-click or bring up the Edge List window and select both the vertical lines. If this is 

difficult, one can zoom in on an edge by holding down the Ctrl button, clicking and 

dragging the mouse to specify an area to zoom in on, and releasing the Ctrl button. To 

return to the main view, click on the Global Control Tool pad > Fit to Window Button 

again. You can also hold down Ctrl and double-click in the window to zoom out to a 

fitting window. To pan the view, hold down the middle mouse button and drag the 

mouse. 

Once a vertical edge has been selected, select Interval Count from the drop down box 

that says Interval Size in the Mesh Edges Window. Then, in the box to the left of this 

combo box, enter 5 for the interval count. 

 
Figure 16. Spacing method of mesh edges 

Click Apply. Nodes appear on the edges showing that they are divided into 5. 
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Figure 17. View of meshing edge 

Repeat the same process for the horizontal edges, but with an interval count of 100.  

Mesh Face 

Now that the edges are meshed, we are ready to create a 2-D mesh for the face. 

Operation Toolpad > Mesh Command Button > Face Command Button >  Mesh 

Faces   

Shift left-click on the face or use the up arrow next to Faces to select the face.  

Click Apply. 

 
Figure 18. View of Mesh face  

Step 3: Specify Boundary Types in GAMBIT 

 

Figure 19. Schematic of the problem domain 

Create Boundary Types 

We'll next set the boundary types in GAMBIT. The left edge is the inlet of the pipe, the 

right edge the outlet, the top edge the wall, and the bottom edge the axis. 
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Operation Toolpad > Zones Command Button >  Specify Boundary Types Command 

Button   

This will bring up the Specify Boundary Types window on the Operation Panel. We will 

first specify that the left edge is the inlet. Under Entity:, pick Edges so that GAMBIT 

knows we want to pick an edge (face is default). 

 
Figure 20. Selection box of entity 

Now select the left edge by Shift-clicking on it. The selected edge should appear in the 

yellow box next to the Edges box you just worked with as well as the Label/Type list 

right under the Edges box. 

Next to Name: enter inlet. 

For Type: select VELOCITY_INLET.  

(Note: Sometimes all the items in a dropdown menu will not be visible. If you cannot 

find the VELOCITY_INLET option in the Type menu, try maximizing the window. If it 

is still not visible, try auto-hiding your taskbar. Right-click on the taskbar and go to 

properties.) 

Click Apply. You should see the new entry appear under Name/Type box near the top of 

the window (figure 21). 

 
Figure 21. Boundary types box  
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Repeat this process for the other three edges according to the following table: 

Table 1: Boundary conditions types  

EdgePosition Name Type 

Left inlet VELOCITY_INLET 

Right outlet PRESSURE_OUTLET 

Top wall WALL 

Bottom centerline AXIS 

You should have the following edges in the Name/Type list when finished: 

 
Figure 22. View of all specified boundary conditions  

Save and Export 

Main Menu > File > Save 

Main Menu > File > Export > Mesh... 

Type in pipe.msh for the File Name: 

Select Export 2D Mesh since this is a two-dimensional mesh. Click Accept. 

Check pipe.msh has been created in your working directory and in the window box it 

will appear this a confirmation message : Mesh was successfully written in a pipe.msh. 

 


